Web Hosting Geeks | Web Hosting Experts
Need help? Call us 1(866)TOP-HOST

14318 reviews 1707 hosting providers

Questions & Answers

Sending emails via TLS/587 not working

Apr 24, 2013 by doner
I am not able to send emails via TLS/587 though I can send emails via SSL/465 but not TLS/587 . I tried using port 465 and 587 for TSL but none of them worked. The connection keeps timing out when I use 587 port and gives a certification warning when I use the port 465.
Can anyone please help me fix this
I appreciate any suggestions
Many thanks

2 Answers

0 votes
Apr 24, 2013 by SmartHost
Exim doesn’t work on Port 587 by default, you have to enable the exim on another port and enter the 587 in WHM. Go Home ->Service Configuration ->Service Manager

TLS / SSL  works by default  on port 465, you would receive a certificate warning only if your server is using a self signed certificate for its hostname. If you bought  a certificate it can be installed to exim
Home ->Service Configuration ->Manage Service SSL Certificates
0 votes
Apr 24, 2013 by TopNet
Check if this port is open in any firewall you installed  or in the CSF configuration editor