Web Hosting Geeks | Web Hosting Experts
Need help? Call us 1(866)TOP-HOST

14625 reviews 1734 hosting providers

Questions & Answers

PHPMyAdmin problem

Feb 14, 2013 by ross
Hi..

I am using PhpMyAdmin and I am using:
ubuntu version 12.04
Apache2
PHP5
MySQL
When I start my PhpMyAdmin, I get this error
phpMyAdmin - Error
The mysqli extension is missing. Please check your PHP configuration.
The phpinfo(); script, doesn’t show any information about MYSQL extension.
How can I fix this? Please help
Thanks

2 Answers

+1 vote
Feb 14, 2013 by SmartHost
The latest phpMyAdmin versions require the extension MYSQLI and wouldn’t work with MYSQL extension.
Run this command to install the packages for the old and new versions.
sudo apt-get install php5-mysql
sudo apt-get install php5-mysqli

Then add the below line to your php.ini and restart Apache
extension=mysqli.so
0 votes
Feb 14, 2013 by TopNet
In your php.ini file, uncomment extension=mysql.so  and then restart your apache