parse error in drupal after upgrading

78 views
asked Aug 5, 2012 in Website Builder by carebare (1,420 points)
Hello
I was upgrading my drupal from 7.9 to 7.10  and then when I tried to access my site  I got the following error
Parse error: syntax error, unexpected T_CLASS
I tried copying my old files of 7.9 but I’m  still getting the same error. I can’t currently access my website and would really appreciate it if anyone can give me a solution for this
Many thanks

2 Answers

0 like 0 dislike
answered Aug 5, 2012 by TopNet (10,360 points)
Add this line “AddType x-mapp-php5 .php " to the htaccess file so the server would not use the default PHP4.

If that didn’t work then add  following lines
AddHandler x-mapp-php5  .php
Action  x-mapp-php5 /system-bin/php5exe
0 like 0 dislike
answered Aug 5, 2012 by SmartHost (9,060 points)
hi there

from Control Panel go to Domains & Web Space -> Global PHP Version and  change PHP 4 to PHP 5 and save!
...