Error updating plugins in WordPress 3.5

376 views
asked Jan 30, 2013 in Website Builder by SunFun (3,000 points)
Hi all
I am currently using WordPress 3.5, when I try to update any plugin I get the bellow error  message
"An error occurred while updating Form: The package could not be installed. “
“PCLZIP_ERR_BAD_FORMAT (-4) : Unable to find End of Central Dir Record signature."
I really have no idea what’s going on and what’s causing this.
I would appreciate any feedback on this
Thank you all.

2 Answers

0 like 0 dislike
answered Jan 30, 2013 by WebGuru (9,280 points)
Create a tmp folder under the wp-content directory make sure you give it writing permissions. Add this line to the last line of your wp-config.php file.
 define('WP_TEMP_DIR', MYPATH . 'wp-content/tmp');
0 like 0 dislike
answered Jan 30, 2013 by expert (14,380 points)
1. Locate the wp-config in the root of your WordPress directory.
2.Take a copy of the wp-config.php file
3.Create a TMP folder in the wp-content
4.Open the wp-config.php file with a text editor
5.Add the following  code to the last line of the file and then save
define ('WP_TEMP_DIR', ABSPATH . 'wp-content/tmp');
...