Web Hosting Geeks | Web Hosting Experts
Need help? Call us 1(866)TOP-HOST

14611 reviews 1734 hosting providers

Questions & Answers

accidentally enabled Force SSL

Apr 14, 2012 by GeekNew
Hi there,

I am using Joomla and I have accidentally enabled Force SSL on my website.I do not have SSL on my server. and now I am not able to access my website because I keep getting redirected to https:// URL. which does not exist. I don't know how to turn the Force SSL off, can anyone please help me solve this.

thanks

1 Answer

0 votes
Apr 14, 2012 by SmartHost
Hi there,

You should enable "Force SSL" only when you have SSL enabled on your site
If you have accidentally enabled the option and SSL isn't set up on your server, you won't be able to turn it off because you'll always be redirected to the https:// website URL.

A work around for this is entering the following line in your /includes/config.php:

define('DP_NO_FORCE_URL', true);

This will disable the automatic redirection, and allow you to regain access to your admin interface and disable the "Force SSL" setting. After you've disabled the setting, you can remove the line from your config file.